Page MenuHomePhabricator

MXGL and AK-12 Unusable after revive.
Closed, ResolvedPublic

Description

This bug is present on vanilla KOTH, v12. It makes the AK-12 and MX weapons with GL unusable after the player is revived. Client-side the wrong ammo shows up for each weapon. When GL is selected the ammo counter says 30 rounds. It is sometimes possible to fire the GL clientside but this does not transfer to the server or any other player.

Steps to reproduce:

  1. Get MXGL och AK-12 with GL
  2. Die.
  3. Get revived.
  4. Gun bugs out and cant be used.

Screenshots:
https://codefourgaming.com/uploads/monthly_2019_05/20190528140944_1.jpg.a14df2c1baa5ca1ec937879116dab89b.jpg
https://codefourgaming.com/uploads/monthly_2019_05/20190528140948_1.jpg.140a1a35e087ae1be6c6a46fbfd2a853.jpg
https://codefourgaming.com/uploads/monthly_2019_05/20190528141548_1.jpg.4c1a178317aa6a137fd383a2f6e53642.jpg
https://codefourgaming.com/uploads/monthly_2019_05/20190528143619_1.jpg.4c2a3b477bda237ff517211b86849ad0.jpg
https://codefourgaming.com/uploads/monthly_2019_05/20190528143617_1.jpg.2a823c512b05089f7aaecbd9b72b3705.jpg

Thread on C4G forums:
https://codefourgaming.com/forums/topic/2709-mx-mx-sw-spawn-w-unloaded-weapon-ammo-bugs/

Event Timeline

Archangel renamed this task from MGGL and AK-12 Unusable after revive. to MXGL and AK-12 Unusable after revive. .May 28 2019, 6:56 PM
Archangel created this task.
Archangel created this object in space S1 Public.
Sa-Matra closed this task as Resolved.Jun 9 2019, 9:14 AM
Sa-Matra claimed this task.
Sa-Matra added a subscriber: Sa-Matra.

Apparently resolved. Couldn't reproduce it either.